首页 > 证券 > 精选文章 > macd选股公式首度详解!老玩家苦心研究的分享,跟上吃肉!
会员精华

macd选股公式首度详解!老玩家苦心研究的分享,跟上吃肉!

编辑时间:2022-06-06 16:45 0 1014 复制链接

在股市中,macd指标是绝大多数的股民朋友熟知的分析工具,一直被沿用至今。可以这么说,macd是众多纷繁指标中不可或缺的一个趋势指标。今天就给大家详细说说macd的选股公式,这也是很多朋友一直以来好奇的,首度详解别错过了!

今日重点:

  • 一、macd五大用处,原来这么好使!

  • 二、首度详解macd选股公式,一个个跟上!

8.jpg

一、macd五大用处,原来这么好使!

一般来说,macd的研判标准主要是围绕快速和慢速两条均线(DIF和DEA线)、红、绿柱线(MACD柱)情况以及它们的形态展开。

 RKedRlsuNNsgs.jpg

这么多人一直执着于它,肯定是有其道理。我们先来看看macd五大用处

1、macd不止可以判断一天,也可以判断一周甚至一个月的走势;

2、可以判断个股和大盘一波下跌行情的开始,以及主力庄家给投资者第二次、第三次的出货机会;

3、能帮助辨认个股和大盘一波行情开始之后主力洗盘或是打压的情况;

4、判断股价的涨幅;

5、结合其他指标发挥更大的作用,如当KDJ指标中的J值发生钝化时,投资者可以结合MACD的情况,从而考虑减仓或者出场。

二、首度详解macd选股公式,一个个跟上!

废话不多说,我们马上看看macd的选股公式,先看第一条:

★零轴上方首次金叉


MACD零轴上方第一次金叉,在市场应用里或者在技术表现里比较常见,其核心逻辑,股票经过一轮上涨之后,MACD零轴下方金叉上来,高位出现洗盘,MACD随之出现死叉调整,之后却没有跌破零轴,反而在零轴上方再次金叉,股价也就走二波,通常很可能是主升浪。

选股公式:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

AA:=CROSS(DIF,DEA)AND DEA0;

BB:=BARSLAST(CROSS(DEA,DIF))AND DEA0;

CC:=REF(BARSLAST(CROSS(DIF,0)20,BARSLAST(CROSS(DEA,DIF))+1);

AA AND BB AND CC;

★零轴上二次金叉

0轴线上,白黄线出现“金叉”后,又出现“死叉”,但不下穿O轴线,几日后在O轴线上再次出现“金叉”,为“轴线上二次金叉”。此形态是主力洗盘所为,短暂盘整后,股价将上扬,可视为积极介入的信号。如果第一次“金叉“后的红波小(红柱短且不长),第二次红波大预示较好的买入时机。

选股公式:

JC:IF(SUM(IF(MACD0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)-HHV(IF(IF(CROSS(MACD.DEA,0),1,0),SUM(IF(MACD0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),0),0)=2 AND SUM(IF(MACD0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)REF(SUM(IF(MACD0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),1),10,0);

★零轴方二次金叉

MACD持续零轴下方运行,在低位出现二次金叉,指数这个时候大概率是阶段性底部,可能是双底形态,也可能是底背离形态,这个看股价和指标的金叉位置。

选股公式:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

低位金叉:=CROSS(DIFF,DEA)AND DIFF-0.1;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA=0));

CROSS(DIFF,DEA) AND DEA0 ANDCOUNT(JCCOUNT=2,21)=1;